2009/01/21

ewfy 0.5.0.1

もうこのへんにしておこうと思ったのに、ちょっと気づいたところをいじっているうちに、いつのまにか大改造に。表面的にはあんまり変わってないと思いますが、新バージョンです。
ewfy 0.5.0.1

ewfapi.dllが不要なので導入が簡単、というのがewfyの特徴の一つですが、EwfPlusからewfyに乗り換えるケースとかではすでにewfapi.dllがあるわけなので、わざわざ効率の悪いewfmgr.exeの方を使うのってどうよ、という気がちょっとするわけです。実際どっちでも大差ないのですが、せっかくewfapi.dllがあるなら使った方がいいんじゃないかと。

そこで、「もしもewfapi.dllがあったらそれを使ってAPIを呼ぶ。なかったら従来どおりewfmgr.exeを使う。」という方式にしてみました。すでにsystem32とかにewfapi.dllが入っていれば、ewfyを更新したら自動的にそれが使われるようになります。デフォルトはewfapi.dllの方が優先ですが、このへんは設定で変更できます。どっちを使っているのかは、「ewfyについて」->「バージョン」で確認できます。


いちおう誤解のないように念を押しておきますが、決してewfapi.dllが必要になったというわけじゃなくて、あれば使うようになった、というだけです。しかもewfapi.dllを使ったからといってewfmgr.exeの場合と比べて明らかなパフォーマンスの差が出るわけでもなく、機能もまったく同じ。はっきり言って、わざわざ手間をかけてまでewfapi.dllを入れるほどのメリットはないと思います。

これ以外にもいくつか、地味に改良しました。
  • 「常に無効」のはずなのに「コミット中」と表示されたりすることがあったので、EWFの監視と状態判定の処理を見直しました。以前よりも安定性が向上していると思います。
  • 要望はまったく来てないですが、多国語対応にしました。日本語環境以外ではメニューとかが英語になります。

3 件のコメント:

匿名 さんのコメント...

こんにちは、非常に便利に使用させていただいています、多国語対応が個人的に良いのですが、できればINIファイルなどで、言語を選べるようにできないでしょうか?(自分は英語版Winを使用していますが、language for non-Unicode programをjapaneseにしていると、日本語になってしまいます)
これからもバージョンUP期待しています。

nsh さんのコメント...

コメントありがとうございます。
ちょうど次のバージョンを作っているところだったので、多国語対応についても改良したいと思います。

nsh さんのコメント...

かなり遅くなりましたが、新バージョン(1.0.0)でこの問題に対応しました。iniファイルで言語を選択することはできませんが、Unicodeアプリになったので、OSが面倒見てくれるようになりました。

Related Posts Plugin for WordPress, Blogger...